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0.1 SimulIDE

You can find the free electronics simulation program SimulIDE in ILIAS under (DE/EN) Software.
Alternatively, the program can also be downloaded from the manufacturer's website. There, a “small
contribution” must be entered, which can also be 0€.

In contrast to TINA TI, SimullDE has a different focus and therefore the following advantages and
disadvantages.

Advantages:

e Microcontrollers are simulated well (including Atmel chips). This is not possible in TINA TI.

e The microcontrollers can also be programmed. This means that microcontroller-suitable source
files (hex files) can be used.

e Interaction between software and hardware is possible.

Disadvantages:

e Simulation of various electronic components is only implemented in a simplified way (e.qg.
operational amplifiers or FETs)

e The software is still being heavily developed. This means it is a good idea to use the version
specified above in order to avoid compatibility problems.

To get started with SimulIDE, it helps to watch the developer's playlist.

Tips for Using SimullDE - Configuration

ﬁ E' DT 6 é é @ Speed: 000.00 %

Time: 0000200 5 000 ms 000 ps 000 ns 000 ps

Z) Settings ? >

App Cincuit Simulation

App Settings Help
Language Endlish -
Font Scale 1.00 =

Fig. 1: Image for configuration
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« If the text is displayed too small after opening the program, one of the following approaches

may help:
o In SimullDE, after opening the program, click on the gear icon. Select the App tab. There,
enter for example 2.0 for Font Scale and restart the program.
o In Explorer: right-click » Properties » Compatibility » Change high DPI
settings » Override high DPI scaling behavior » check the box »
select “System”. (if necessary, choose “System (Enhanced)”)

0.2 Microchip Studio

Microchip Studio is a programming environment for creating a microcontroller-suitable source file
(hex file) from C or C++.

Installation

Installation Guide

The current version of the program can be found on the Microchip homepage.

1.

W

9.

If nothing happens after pressing the Download Microchip Studio button: simply scroll
down to Downloads and Documents

. With fast internet connections, the web installer can be chosen; with slower connections, the

offline installer allows the entire package to be downloaded before installation.
During installation, only the “AVR” architecture is required.
“Advanced Software Framework and Example Projects” are not required.

. Depending on the speed of the computer and the internet connection, installation takes about 5

minutes.
If it is not already installed, Visual Studio will also be installed during installation.
The question about licenses for the C compiler should be skipped with Next >

. In addition, various device drivers may also be installed. These make it possible to write to the

chips using a programming device.
Afterwards, open Microchip Studio directly so that you can make the first important settings.

for Mac Users

The following procedure is especially recommended for Mac users:

© N U A WN

Open a browser.

Establish a VPN connection via eduVPN.

Go to fernzugriff-pools.hhn.hs-heilbronn.de

Log in and select a computer.

Select Mr. Ziegler's image with “uC_PCB” (search for Ziegler)

Then it will take a little while, because the pool computer now starts the Windows image.
You can now access a PC with Microchip Studio through your browser.

Please note that all data is deleted after ending the session.

This means it is a good idea to set up the “U:” drive (“home directory”). Please contact Mr.
Ziegler for this.
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First Test of the Connection to the AVR-USB-Progi

Carry out the following steps to perform an initial test with the hardware.

1. Preparations
1. Connect the MiniMEXLE
1. to the Progi (black box) via ribbon cable
2. to the power outlet via charging cable with the barrel connector
2. Open Microchip Studio (for example by pressing the <WIN> key, entering Microchip
Studio, and pressing <Return>).
3. Download the file 5._menufuehrung.hex.
4. After opening the program, connect the Progi to the PC / laptop via USB cable. This step
must be done before the following ones!
5. The green LED for USB communication should light up on the Progi.
2. Enter USB connection
1. Without creating a project, go directly to Tools » Add Target...
2. In the displayed window, you should select STK500 as the tool in the dropdown menu,
which was previously empty.
3. For the selection of the “Serial Ports”, choose the first available one, e.g. COM3, and
confirm the selection with Apply.
If no port is shown here, check whether the connection to the USB-Progi was successful.
If the green LED is lit and the USB cable is connected correctly, refer to the instructions
under 4.d.
3. First connection attempt
1. Select Tools » Device Programming in the menu.
2. Under Tools, select the corresponding USB connection, e.g. STK500 COM3.
3. Under Device, you must select ATmega88; you can enter 88 and then click the correct
value in the dropdown menu.
4. Under Interface, ISP should now be shown.
5. Now press Apply.
4. In case of error:
1. If it takes longer after pressing Apply, the connection did not work. An error message
Unable to connect tool STK500 (COMx) will then be displayed.
2. You can acknowledge the error message, but after that it takes a few more seconds until
the program responds correctly again.
3. Then close the Device Programming window. Go back to point 2 in this guide and try
the next serial port.
Remember the number of the port, as this is needed under 3.b.
4. If all available COM ports have been tested, or none were displayed from the beginning,
installing a Virtual COM Port Driver may help. One can be found at FTDI.
5. If it works:
1. You should now see a bit more in the Device Programming window.
2. Before the next steps, connect the MiniMEXLE (= board with display and buttons) to the
Progi with the ribbon cable and to the power supply with the barrel connector. Also plug
the power supply into an outlet.
3. Now press Read at the top next to Device Signature.
4. A hexadecimal number 0x... should appear. Your computer can now establish a
connection to the MiniMEXLE for flashing.
5. Inthe Device Programming window, go to Memories. Under Flash, insert the path to
the downloaded file 5. menufuehrung.hex. You can also select the path using the ...
button to the right.
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6. Press Program
7. The MiniMEXLE should now display
- Experiment 5 -
Program Menu
and then
Main Level
P1 P2 P3 P4
8. This means you have successfully tested the connection and the flashing process

Important Settings

e Use the display of line numbers: Tools » Options » Text Editor » All languages
» General » Line numbers
¢ As soon as you work on the first project: Make sure to disable compiler optimization. This can be
done with the following steps:
o Menu Project » <ProjectName> Properties.. » AVR/GNU Compiler »
Optimization
o The optimization level should be set to None (-00)
e | recommend using ATMEL Studio in English. This makes the instructions in this course easier to
follow correctly. If you accidentally selected German (e.g. during installation), you can correct it
under Tools » Options » environment » international settings » Language.

Tips

« |f the Solution Explorer (display of the files in the project) is not present on the right-hand
side, you can find it under
View » Solution Explorer (<CTL>+<ALT>+<L>)

Haufige Fehler

e F_CPU not defined for (z.B. <util/delay.h>) Das beste ist die Frequenz F_CPU im AVR Studio
direkt anzugeben:

o Gehe zu Menu: Projekt » (ProjektName) Eigenschaften » Toolchain »
AVR/GNU C Compiler » Symbols
o Flige F_CPU=8000000 (bzw. Passende Frequenz) ein

* Das Programm kompiliert nicht TWSR not found : Falls Sie einen modernen AVR Chip
nutzen (z.B. 328PB) so kann dieser mehrere SPI und 12C Schnittstellen haben. Damit haben sich
bei diesem Target auch die Register- und Interruptvektornamen geandert. Statt TWSR ist dann
TWSRO oder TSWR1 zu verwenden - je nach gewlnschtem Pin. Dies ist am einfachsten Gber
defines der fehlerhaften Namen, also #define TWSR TWSRO usw.

e Beim Flashen der realen Hardware iiber Tools » Device Programming finde ich im
Tool nur “Simulation”, aber kein STK500. Versuchen Sie zunachst Gber Tools » Add
tagret... STK500 und den entsprechenden Serial Port zu wahlen. Falls Ihr Rechner mehrere USB
Ausgange hat, mussen Sie diese (COM1...COMx) beim Programmieren ausprobieren.

* Beim Flashen der realen Hardware erhalte ich “Erasing device failed”, “Error status
received: Got 0xc9, expected 0x00 (An unknown command was sent)“.

o Steht bei Device Programming das Interface auf ISP? Falls nicht kann dies die Ursache
sein. Das Programming geschieht immer mittels ISP.
o Hat das USB-Kabel/Progi/Adapterplatine/Kabel ein Problem? Probieren Sie eine andere
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Variante der Komponenten durch
e Mein Chip hat keinen Speicherplatz mehr bzw Ich erhalte ein 'Memory Overflow'
Fehler Falls Sie Daten statt im SRAM im EEPROM speichern wollen, so kénnen Sie das
Befehlswort “PROGMEM” nutzen. Details dazu finden Sie z.B. auf der Seite von Microchip
¢ Mein Programm scheint irgendwo nicht weiter zu kommen. Dies kann verschiedene
Grinde haben:
o Endlosschleife
o SpeicherUberlauf im RAM: sobald die Speicherauslastung des RAM Uber ca 75% steigt,
sind Probleme wie spontane Resets bei Bearbeiten von Pointern, Arrays, Strings oder
Structs wahrscheinlich. Die kann Uber Debugging herausgefunden werden (entweder mit
Steppen mit Debugger oder Ausgabe von Werten nach jeder Zeile).

12C

e Auf den I2C Leitungen andert sich nichts, obwohl der IC etwas ausgeben sollte:

1. Uberpriifen Sie die Pullup-Widerstéande: Sind welche verbaut? Welche GréRe haben diese?
(typisch: 10kOhm). Wenn keine Verbaut sind, so wechselt das Signal nur zwischen 0V
niederohmig und 0V hochohmig. Dies ist am Oszilloskop nicht zu unterscheiden.

2. Ist ein hochohmiger Widerstand $R_L$ entlang der Leitungen verbaut? Falls ja erzeugt
dieser einen Spannungsteiler mit dem Pullup-Widerstand. Wenn $R _L$ groR ist, so liegt
zwischen $R_L$ und Pull-up fast die Versorgungsspannung an.

e Der Master soll Daten vom Slave empfangen, aber hangt sich manchmal auf Im
“Master Receiver Mode” muss der Master das Ende der Kommunikation dem Slave mitteilen.
Dazu muss beim Lesen der Daten TWEA = 0 gesetzt werden. Ansonsten kann es sein, dass der
Slave meint er musse noch Daten senden. Das kann unter Umstanden dazu fuhren, dass der
Slave die Datenleitung SDA am Ende der Kommunikation auf Low legt und damit den 12C stort.

0.3 MEXLE GitLab

Installation der Software auf lhrem Rechner

1. Laden Sie Git von folgender Seiter herunter: https://git-scm.com/download/win » “Standalone
Installer”

Git bietet die Méglichkeit mit dem GitLab Server der Hochschule oder mit GitHub in Kontakt zu
treten

2. Installieren Sie das Git (alle mit “Ok” bzw “Weiter” bestatigen)

3. Laden Sie TortoiseGit von folgender Seite herunter: https://tortoisegit.org/download/
totroiseGit bindet den Explorer direkt an die Services des Git an. Damit ist Git direkt in den
Explorer eingebunden.

4. Installieren Sie das TortoiseGit (alle Hinweise mit “Ok” bestatigen)

Anmeldung beim MEXLE GitLab

1. Melden Sie sich bei GitLab mit den Hochschul-Credentials an: https://git. mexle.org/
2. Gehen Sie zu User settings » Preferences » Password:
z.B. Uber folgenden Link: https://git.mexle.org/-/user_settings/password/edit
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3. Geben Sie ein Passwort mit mindestens 16 Zeichen ein und merken Sie sich dieses Passwort.
Dieses Passwort ermdglicht die Authentifizierung auf GitLab.
Bitte nutzen Sie ein neues Passwort!

Installation der Software auf lhrem Rechner

Die Abfolge ist wie folgt:

' 1. Erst mussen Sie sich in GitLab anmelden
2. Dann mussen Sie einem Betreuer per Mail bescheid geben (Prof. Fischer, Ralf

Ziegler) , damit dieser Sie zum Projekt zuordnet
3. Erst dann sind einem Projekt zugewiesen und konnen die folgenden Punkte
durchfuhren.

1. Gehen Sie in den (Windows) Explorer und legen Sie einen neuen Ordner fur die Vorlesung an,
z.B. Mikrocontroller oder Elektronik Labor

2. Klicken Sie mit der rechten Maustaste auf den Ordner, um in das Kontextment zu kommen.
Wéblen Sie dort Git Clone.. aus.

& Git Clone... I

| | it Create repository here...

42 TortoiseGit p
lem Dl limdl m e o iFem m b s i A

3. Im erscheinenden GitClone Fenster sollten Sie Folgendes eingeben:
1. als URL: https://git.mexle.org/[Fach]/[Semester].git
also z.B. https://git.mexle.org/mikrocontroller/26ss.git oder
https://git.mexle.org/elektronik/26ss.git fur das Sommersemester 2026
2. als Directory sollte der ausgewahlte Ordner eingetragen sein
3. Klicken Sie nun auf Ok

MEXLE Wiki - https://wiki.mexle.org/
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#" Git clone - TortoiseGit

Clone Existing Repository

URL: s/ git.mexle.org/mikrocontroller/24ws. git Browsze...
[] Depth 1 [ Recursive ] Clone into Bare Repo [IMo Checkout
[]Branch |:|Origir1 Mame

[ Load Putty Key ehret31. Mikrocontrollertechnik\GIT 55H private Key.ppk

From SVN Repository

[ From SVM Repository

From: 0 Uzername:

Trunk: trunk Tags: tags Branch: branches

4. Im Anschluss sollten Sie eine Fehlermeldung erhalten, da noch das Passwort fehlt.
Hier ist nun das vorher gewahlte Passwort einzugeben.
Dies mlssen Sie auch nur einmalig machen.

5. Der Download sollte nun klappen und es sollten alle Ordner heruntergeladen werden

Upload / Commit von Dateien

Das Hochladen und Andern von Dateien bei Git wird als “Commit” bezeichnet. Diese Nomenklatur

wird auch im Folgenden genutzt.

Im Folgenden wird ein Upload beschrieben; Gber einen Commit kdnnen aber auch Dateien geldscht

werden.

B e e it

= Git Sync...
I e Git Commit -= "main"...
& TortoiseGit >
In Riklinthzl anfreshmen ™

2. Falls eine Fehlermeldung erscheint, siehe nachstes Kapitel
3. Im folgenden Fenster ist nun einiges einzutragen:

1. Tragen Sie unbedingt einen Text unter Message ein, ansonsten ist kein Upload mdglich!

Schreiben sie einen Text, welcher die Anderungen beschreibt.
2. Im unteren Teil sind die zu andernden Dateien zu markieren.
Entweder Sie wahlen die Dateien einzeln aus, oder Sie wahlen z.B. ALl .

3. Zum Commit an den Server wahlen Sie am Button unten v aus und dort Commit & Push

MEXLE Wiki - https://wiki.mexle.org/
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Commit to:

Message:

main [ ] new branch

" DAGitLab\mikrocontreller\2dws - Commit - TortoiseGit

— O X

Text-Datei eingefil

[] Amend Last Commit
[] set author date

[] set author

TimFischer <tim . fischer@hs-heilbron:

Changes made (F5: refresh, double-click on file for diff):

Add Signed-off-by

170

Check:

All Mone Unversioned

Files

Path

L4

Llot Yersioned Files

[ || text.bet

>

[ Staging support (EXPERIMEMNTAL)
Show Unversioned Files

[] Do not autoselect submodules

Show Whole Project

[] Message only

Commit & Push

Commit

ReCommit

1 files zelected, 1 files total

Cancel

View Patch> =

Help

Commit & Push

4. Bestatigen Sie nun den Commit Uber Druck auf den Button Commit & Push
4. Uberpriifen Sie, ob der Commit erfolgreich war durch einen Blick auf die Homepage des

Projekts.

Hinweise und Mogliche Fehler

1. FUr Abschlussarbeiten und studentischen Projekte:

1. Da diese haufig mehr als 100 MB hochladen, sollten Sie nicht
https://git.mexle.org/...

nutzen, sondern:

http://git.mexle.te.hs-heilbronn.de/....

2. In diesem Fall mUssen Sie im Hochschulnetz befinden (z.B. per eduVPN).

3. Fragen Sie bei mir (Tim Fischer) nach, welches Git Repository fur Sie das passende ist.

MEXLE Wiki - https://wiki.mexle.org/
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2. fatal: detected dubious ownership in repository at [..] is on a
filesystem that does not record ownership
Das Problem ist, das der Ordner auf einem Laufwerk liegt, welches keine Benutzerzuordnung
erlaubt (z.B. ein USB-Stick) .
Die Losung wird gleich mitgeliefert:
1. Rechtsklick im Explorer auf den entsprechenden Ordner (z.B. 24WS) » Open Git Bash
here » Es dffnet sich eine Text-Konsole
2. Flgen Sie Folgendes ein git config --global --add safe.directory
D:/GitLab/elektronik/25WS (andern Sie ggf. elektronik in mikrocontroller
und das Semester) und bestatigen Sie mit Return
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