Hilfsmittel

Das kostenlose Elektronik-Simulationsprogramm SimulIDE ist über diese Wikiseite herunterladbar. Im Gegensatz zu TINA TI hat dieses Programm einen anderen Fokus und damit folgende Vor- und Nachteile:

Vorteile:

  • Microcontroller wird gut simuliert (u.a. von Atmel Chips). Das ist in TINA TI nicht möglich.
  • Die Microcontroller sind auch programmierbar. D.h. man kann Microcontroller-geeignete Source-File (hex-File) nutzen.
  • Interaktion Software und Hardware ist möglich.

Nachteile:

  • Simulation von verschiedenen Elektronikkomponenten nur vereinfacht implementiert (z.B. Operationsverstärker oder FETs)
  • Software ist recht neu, damit nicht immer stabil. Einige Kinderkrankheiten sind aber bereits ausgemerzt

Zur Einführung hilft es die Playlist des Entwicklers anzusehen.

Microchip Studio

Microchip Studio ist eine Programmierumgebung, um aus C oder C++ ein Microcontroller-geeignetes Source-File (hex-File) zu erstellen.

Die aktuelle Version des Programms finden Sie auf der Microchip-Homepage.

  1. Falls nach dem Drücken des Buttons Download Microchip Studio nichts passiert: einfach herunterscrollen zu Downloads and Documents
  2. Bei schnellen Internetverbindungen kann der Web Installer gewählt werden, bei langsamen lässt sich mit dem Offline Installer das gesamte Paket vor der Installation herunterladen.
  3. Bei der Installation ist als Architektur nur „AVR“ notwendig.
  4. „Advanced Software Framework and Example Projects“ sind nicht notwendig
  5. Die Installation dauert je nach Geschwindigkeit des Rechners und der Internetverbindung etwa 5 Minuten
  6. Falls nicht schon installiert, wird bei der Installation auch Visual Studio mit installiert
  7. Die Frage nach Lizenzen für den C compiler ist mit Next > zu überspringen
  8. Weiterhin kann es sein, dass verschiedene Geräte-Treiber mit installiert werden. Diese ermöglichen das Beschreiben der Chips mit einem Programmiergerät.
  9. Öffnen Sie im Anschluss direkt Microchip Studio, damit Sie die ersten, wichtigen Einstellungen vornehmen können.
  • Nutzen Sie die Anzeige von Zeilennummern: Tools » Options » Text Editor » All languages » General » Line numbers
  • Sobald Sie das erste Projekt bearbeiten: Deaktivieren Sie unbedingt die Compiler Optimierung. Dies geht mit folgenden Schritten:
    • Menu Project » <ProjectName> Properties… » AVR/GNU Compiler » Optimization
    • Das Optimization level sollte hier auf None (-O0) stehen
  • Ich empfehle ATMLE Studio in der Sprache „English“ zu nutzen. Damit sind die Hinweise in diesem Kurs korrekt zu finden. Falls Sie versehentlich (z.B. bei der Installation) die deutsche Sprache eingestellt hatten, können Sie es unter Werkzeuge » Optionen » environment » international settings » Language korrigieren.
  • Falls auf der rechten Seite der Solution Explorer (Anzeige der Dateien im Projekt) nicht vorhanden ist, so finden Sie diesen unter
    View » Solution Explorer (<CTL>+<ALT>+<L>)

Häufige Fehler

  • F_CPU not defined for (z.B. <util/delay.h>) Das beste ist die Frequenz F_CPU im AVR Studio direkt anzugeben:
    • Gehe zu Menu: Projekt » (ProjektName) Eigenschaften » Toolchain » AVR/GNU C Compiler » Symbols
    • Füge F_CPU=8000000 (bzw. Passende Frequenz) ein
  • Das Programm kompiliert nicht TWSR not found : Falls Sie einen modernen AVR Chip nutzen (z.B. 328PB) so kann dieser mehrere SPI und I2C Schnittstellen haben. Damit haben sich bei diesem Target auch die Register- und Interruptvektornamen geändert. Statt TWSR ist dann TWSR0 oder TSWR1 zu verwenden - je nach gewünschtem Pin. Dies ist am einfachsten über defines der fehlerhaften Namen, also #define TWSR TWSR0 usw.
  • Beim Flashen der realen Hardware über Tools » Device Programming finde ich im Tool nur „Simulation“, aber kein STK500. Versuchen Sie zunächst über Tools » Add tagret… STK500 und den entsprechenden Serial Port zu wählen. Falls Ihr Rechner mehrere USB Ausgänge hat, müssen Sie diese (COM1…COMx) beim Programmieren ausprobieren.
  • Beim Flashen der realen Hardware erhalte ich „Erasing device failed“, „Error status received: Got 0xc9, expected 0x00 (An unknown command was sent)„.
    • Steht bei Device Programming das Interface auf ISP? Falls nicht kann dies die Ursache sein. Das Programming geschieht immer mittels ISP.
    • Hat das USB-Kabel/Progi/Adapterplatine/Kabel ein Problem? Probieren Sie eine andere Variante der Komponenten durch
  • Mein Chip hat keinen Speicherplatz mehr bzw Ich erhalte ein 'Memory Overflow' Fehler Falls Sie Daten statt im SRAM im EEPROM speichern wollen, so können Sie das Befehlswort „PROGMEM“ nutzen. Details dazu finden Sie z.B. auf der Seite von Microchip
  • Mein Programm scheint irgendwo nicht weiter zu kommen. Dies kann verschiedene Gründe haben:
    • Endlosschleife
    • Speicherüberlauf im RAM: sobald die Speicherauslastung des RAM über ca 75% steigt, sind Probleme wie spontane Resets bei Bearbeiten von Pointern, Arrays, Strings oder Structs wahrscheinlich. Die kann über Debugging herausgefunden werden (entweder mit Steppen mit Debugger oder Ausgabe von Werten nach jeder Zeile).
  • Auf den I2C Leitungen ändert sich nichts, obwohl der IC etwas ausgeben sollte:
    1. Überprüfen Sie die Pullup-Widerstände: Sind welche verbaut? Welche Größe haben diese? (typisch: 10kOhm). Wenn keine Verbaut sind, so wechselt das Signal nur zwischen 0V niederohmig und 0V hochohmig. Dies ist am Oszilloskop nicht zu unterscheiden.
    2. Ist ein hochohmiger Widerstand $R_L$ entlang der Leitungen verbaut? Falls ja erzeugt dieser einen Spannungsteiler mit dem Pullup-Widerstand. Wenn $R_L$ groß ist, so liegt zwischen $R_L$ und Pull-up fast die Versorgungsspannung an.
  • Der Master soll Daten vom Slave empfangen, aber hängt sich manchmal auf Im „Master Receiver Mode“ muss der Master das Ende der Kommunikation dem Slave mitteilen. Dazu muss beim Lesen der Daten TWEA = 0 gesetzt werden. Ansonsten kann es sein, dass der Slave meint er müsse noch Daten senden. Das kann unter Umständen dazu führen, dass der Slave die Datenleitung SDA am Ende der Kommunikation auf Low legt und damit den I2C stört.